微信图片_20220506153608

谷歌修复了积极利用的 Android 内核漏洞

  • 浏览次数 19966
  • 喜欢 0
  • 评分 12345

微信图片_20220506153608

近期谷歌发布了Android的5月安全补丁的第二部分,其中包括对积极利用的Linux内核漏洞的修复。该漏洞编号为CVE-2021-22600,是Linux内核中的一个权限提升漏洞,威胁者可以通过本地访问来利用该漏洞。由于Android使用修改后的Linux内核,因此该漏洞也会影响操作系统。

谷歌的研究人员曾在1月份就披露了该Linux漏洞 ,并引入了一个修复程序,该修复程序也及时同步给Linux供应商,然而在谷歌自己的安卓操作系统中修复这个漏洞则需要几个月的时间。

4月,CISA披露该漏洞正在被积极利用,并将其添加到其“已知被利用漏洞目录”中。在5月的Android安全公告中,谷歌确认该编号为CVE-2021-22600的漏洞可能被有针对性的利用。目前尚不清楚该漏洞是如何被用于攻击的,但它很可能被用于执行特权命令并通过企业网络中的Linux系统横向传播。

最近的Android版本(10、11、12)包含了越来越严格的权限,使得恶意软件很难获得高级功能所需的权限。因此,在感染后利用漏洞来获得更高的特权并非不可能。此漏洞的第二个潜在用途是用户安装并激活后,可以在设备上获得root权限的设备root工具。

以下是本月修复的内容摘要:

  • Android框架中的四个提权 (EoP) 和一个信息泄露 (ID) 漏洞
  • Android系统中的三个EoP、两个ID 和两个拒绝服务(DoS) 漏洞
  • 内核组件中的三个EoP 和一个 ID 缺陷
  • 联发科组件中的三个高危漏洞
  • 高通组件中的15个高严重性和1个严重严重性缺陷

需要注意的是,针对CVE-2021-22600和所有来自第三方供应商的修复程序都在2022-05-05 安全补丁程序级别上可用,而不是在2022年5月1日发布的第一个安全补丁程序级别上可用。无论如何,所有这些修复仍然包含在下个月的第一个安全补丁级别中,该补丁将于 2022 年6月1日发布。

同时,该安全补丁并不适用于Android 9或更早版本,建议用户出于安全原因,应该升级到更新的Android操作系统版本。使用Google Pixel设备的用户本月收到了额外的修复,其中一个仅影响使用Titan-M芯片的最新Pixel 6 Pro系列。最有趣的两个是漏洞是CVE-2022-20120和CVE-2022-20117,一个是影响引导加载程序的严重远程执行漏洞,一个是Titan-M上的严重信息泄露漏洞。


转自 FreeBuf ,原文链接:https://www.freebuf.com/articles/332228.html

封面来源于网络,如有侵权请联系删除