可用

思科修复了允许攻击者以 root 身份执行命令的 BUG

  • 浏览次数 8154
  • 喜欢 0
  • 评分 12345

1658380042_62d8df0a5f33be43b8ed3

近期,思科解决了Cisco Nexus Dashboard数据中心管理解决方案中的严重漏洞,这些漏洞可让远程攻击者以root或管理员权限执行命令和操作。

第一个安全漏洞(被评为严重严重性漏洞,编号为 CVE-2022-20857)使未经身份验证的威胁参与者能够通过发送HTTP 请求来访问API,并以root 权限远程执行任意命令。

第二个漏洞(Web UI 中的一个高严重性漏洞,编号为 CVE-2022-20861)允许远程攻击者通过欺骗经过身份验证的管理员单击恶意链接来进行跨站点请求伪造攻击。

对此,思科也作出了解释,利用该漏洞可能允许攻击者在受影响的设备上以管理员权限执行操作。而近期修补的另一个高严重性安全漏洞 (CVE-2022-20858) 可以让未经身份验证的远程攻击者通过打开与容器镜像管理服务的TCP连接来下载容器镜像或将恶意镜像上传到受影响的设备。幸运的是,正如思科在发布的安全公告中解释的那样,恶意图像将在设备重启或Pod重启后运行。不过这些漏洞影响Cisco Nexus Dashboard 1.1及更高版本。思科已解决近期发布的2.2(1e)安全更新中的漏洞,并建议客户尽快迁移到固定版本。

这些安全漏洞是由思科高级安全计划小组 (ASIG) 的安全研究人员在内部安全测试期间发现的。思科的产品安全事件响应团队 (PSIRT) 表示,目前暂不知道公开可用的漏洞利用或在野外的积极利用。同时思科还修补了Cisco Nexus 仪表板的SSL/TLS实施中的第四个漏洞 (CVE-2022-20860),该漏洞可能让未经身份验证的远程威胁参与者通过拦截中间人攻击中的流量来改变通信,利用该漏洞还可能允许攻击者查看敏感信息,包括受影响控制器的管理员凭据。思科表示之所以存在此漏洞,是因为当 Cisco Nexus Dashboard 与 Cisco 应用策略基础设施控制器 (APIC)、Cisco Cloud APIC 或 Cisco Nexus Dashboard Fabric Controller(以前的数据中心网络管理器 (DCNM) 控制器)建立连接时,未验证 SSL 服务器证书。


转自 FreeBuf,原文链接:https://www.freebuf.com/news/339721.html

封面来源于网络,如有侵权请联系删除