可用

Linux 被爆“满分级”关键内核级漏洞

  • 浏览次数 11290
  • 喜欢 0
  • 评分 12345

据Security Affairs消息,近期披露的一个严重 Linux 内核漏洞会影响 SMB 服务器,可能导致远程代码执行。

该漏洞的 CVSS 评分达到了最高级别的10分,影响启用了 KSMBD 的服务器。KSMBD 是一个 Linux 内核服务器,它在内核空间实现 SMB3 协议,用于通过网络共享文件,未经身份验证的远程攻击者可以在易受攻击的 Linux 内核安装上执行任意代码。

趋势科技在其网站上的发布的漏洞披露显示,虽然利用此漏洞不需要身份验证,但只有启用了KSMBD 的系统容易受到攻击。漏洞存在于 SMB2_TREE_DISCONNECT 命令的处理过程中,是由于在对象执行操作之前没有验证对象的存在,攻击者可以利用此漏洞在内核上下文中执行任意代码。

Thales Group 的 Thalium 团队的研究人员于今年7月26日首次发现了该漏洞,12 月 22 日该漏洞得到公开披露。

云安全初创公司 wiz.io 的研究主管Shir Tamari表示,由于 KSMBD 模块不像 Samba 套件那样流行,因此尽管漏洞很严重,但其潜在影响可能有限。该漏洞仅影响使用 Linux 5.15 中引入KSMBD 模块的 SMB 服务器。若用户的 SMB 服务器使用 Samba,则不会受到任何影响。

为此,使用 KSMBD的用户必须更新到自8 月之后发布的新版Linux 内核版本——5.15.61及以上版本。

 


转自 Freebuf,原文链接:https://www.freebuf.com/news/353584.html

封面来源于网络,如有侵权请联系删除