可用

Ubuntu 曝出漏洞,近 40% 的用户容易受到影响

  • 浏览次数 24086
  • 喜欢 0
  • 评分 12345

Bleeping Computer 网站披露,Wiz 研究人员 s.Tzadik 和 s.Tamari 发现 Ubuntu 内核中存在两个 Linux 漏洞 CVE-2023-32629 和 CVE-2023-2640,没有特权的本地用户可能利用其在设备上获得更高权限,影响大约 40% 的 Ubuntu 用户。

屏幕截图 2023-07-27 141250

Ubuntu 是目前使用最广泛的 Linux 发行版之一,拥有大约 4000 多万用户。

CVE-2023-2640 是存在于 Ubuntu Linux 内核中的一个高严重性(CVSS v3得分:7.8)漏洞,之所以出现是因为权限检查不充分,从而允许本地攻击者获得过高的权限。另外一个漏洞 CVE-2023-32629 是存在于 Linux 内核内存管理子系统中的一个中等严重性(CVSS v3 分数:5.4)漏洞,允许本地攻击者执行任意代码。

s.Tzadik 和 s.Tamari 两位分析师发现在 Linux 内核上实现 OverlayFS 模块的差异后,找到了这两个漏洞问题。(OverlayFS 是一种联合装载文件系统实现,因其允许通过用户名称空间进行无特权访问,并且受到容易被利用的漏洞的干扰,过去曾多次受到威胁攻击者的攻击)

Ubuntu 作为使用 OverlayFS 的发行版之一,在 2018 年对其 OverlayFS 模块进行了自定义更改,总体上来说应该是安全的。 然而在 2019 年和 2022 年,Linux 内核项目对该模块进行了修改,这就与 Ubuntu 的更改起了冲突,新版本广泛分发采用了包含这些更改的代码,因此冲突引入了这两个漏洞。更不幸的是,这两个漏洞存在被利用的风险,毕竟它们的 PoC 已经公开了很长一段时间。

 

1690437432_64c20738e5489f54bc1e2

Wiz研究人员警告称这两个漏洞源于 Ubuntu 对 OverlayFS 模块的单独更改,都针对 Ubuntu 内核,目前针对这些漏洞的武器化攻击已经公开。需要注意的是这两个漏洞只会影响 Ubuntu,其它包括 Ubuntufork 在内的 Linux 发行版以及不使用 OverlayFS 模块的自定义修改都应该是安全的。

近期,Ubuntu 发布了一份关于最新版本Ubuntu Linux 内核中存在六个漏洞的安全公告,并提供了修复更新版本, 建议尚不清楚如何重新安装和激活第三方内核模块的用户通过包管理器执行更新(包管理器应负责所有依赖项和安装后配置)。此外, 用户要注意安装 Linux 内核更新后,需要重新启动才能在Ubuntu 上生效。

 

 

 

 

 


转自Freebuf,原文链接:https://www.freebuf.com/news/373188.html

封面来源于网络,如有侵权请联系删除